User Tools

Site Tools


This is an old revision of the document!

Problems with compiling

Automake complains or AM_GNU_AS Error

You need a recent version of automake and autoconf.


You need to install the “gettext-dev” package

Build fails at ADM_codecfaad.cpp

One of two things happened.

  1. You need to provide the –with-newfaad switch for ./configure
    ./configure --with-jsapi-include=xxxx --with-newfaad

    This is needed for the linux distribution of Gentoo and Ubuntu.

  2. You do not need to give the –with-newfaad switch for ./configure. The solution is try the ./configure command without it –with-newfaad.


Some people have mentioned problems compiling Avidemux with GNU compilers of version the 4.0 series. If you have any problems with cputest.o or MM_MMX, MM_MMXEXT, MM_SSE, MM_SSE2, MM_3DNOW, MM_3DNOWEXT, try using a GNU gcc/g++ compiler from before version 4.0.

gtkxxx fail

If the ./configure command fails with the message saying “Cannot open gtkxxx”, it usually means that pkg-config/gtk+/glib is not installed or configured properly.

You should make sure that you have pkg-config, pkg-config-dev, libgtk-dev, and glib-dev (or libglib-dev) packages properly installed so that you can compile with them.

If the compilation fails at the link stage with JPEG MMX, you need to find the file “”. (It is often in /usr/lib/ or /usr/local/lib). From the console you can use the 'find' or the 'locate' commands to find it. Once you have found the file, open the file in a text editor and look at it.

If you see this line of code in the file:

dependency_libs=' -L/usr/src/redhat/BUILD/mjpegtools-1.6.0/jpeg-mmx -ljpeg-mmx'

Change it to:


Trouble with jsapi

If you have trouble with jsapi, one of two things has happened.

  1. If it had trouble finding jsapi.h, the solution is simple.
    ./configure --with-jsapi-include=xxxx [[--with-newfaad|for gentoo or ubuntu]]

    Using the 'locate jsapi.h' command will usually find the directory you need with the jsapi.h file. Replace the xxxx is the directory where jsapi.h is.

  2. If there was a problem locating the library, the trouble could be several things.
    • One probability is the,, and other necessary libraries are not in the standard path. You can either add them to your path value or you can put symlinks /usr/lib to the libraries themselves.
    • Another cause for the library problem could be a clash between an older installed version with a new version of SpiderMonkey. You can check the config.log to look for the ctype_b error. If you find that, you have a version conflict, and you will need to remove the older version (and probably the newer version), then install a clean copy of the new version. Though all those steps are not always necessary. Eitherway, you need to clear up the version conflict.
    • You could also have an inappropriate version of the libary. You could have a 32-bits version on a 64-bits system. Simply install the correct version to fix the problem. You can read the config.log file to find out what happened and get an idea if this is the problem.
build/problems_with_compiling.1271392828.txt.gz · Last modified: 2012/11/11 08:51 (external edit)