Author Topic: [RESOLU] x264 paquet ubuntu ou compilé?  (Read 1037 times)

alexdaums

  • Newbie
  • *
  • Posts: 17
[RESOLU] x264 paquet ubuntu ou compilé?
« on: January 22, 2013, 04:18:03 PM »
Bonjour,

J'ai compilé la dernière version svn de avidemux 2.6 et je souhaiterais savoir si il me vaut mieux utiliser le codec x264 fournit par ma distribution (ubuntu 12.04 64bits) ou bien il me vaudrait mieux compiler aussi la dernière version de x264?

Merci d'avance de vos réponse!
« Last Edit: January 26, 2013, 08:43:58 PM by alexdaums »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 3372
Re: x264 paquet ubuntu ou compilé?
« Reply #1 on: January 24, 2013, 07:48:26 AM »
Si je ne me trompe pas, avidemux cherche x264 existantes sur le système d'exploitation. S'il n'est pas présent il utilise l'interne.
Avant de compiler avidemux, c'est ce que je fais le 1er:

1er temps:
Code: [Select]
git clone git://git.videolan.org/x264.git ~/source/x264la mise à jour:
Code: [Select]
cd ~/source/x264 && git pullcompilation
Code: [Select]
cd ~/build/x264
~/source/x264/configure --prefix=/usr
make -j4
sudo make install
informations: ubuntu 12.04.1 LTS amd64
 répertoire avec le code source: ~/source/x264
 répertoire de compilation: ~/build/x264
 nombre de cœurs CPU réelle: -j4
 remplacer les emplacements correspondant à votre système: ~/build/x264, ~/source/x264

alexdaums

  • Newbie
  • *
  • Posts: 17
Re: x264 paquet ubuntu ou compilé?
« Reply #2 on: January 24, 2013, 08:18:34 AM »
Merci pour ton aide c'est bien ce que je faisais mais je pense que pour que Ubuntu prenne en compte la nouvelle installation de x264 avant de compiler avidemux il m'a fallut rajouter cette commande.
Code: [Select]
sudo ldconfig
Et depuis c'est nikel...

alexdaums

  • Newbie
  • *
  • Posts: 17
Re: [RESOLU] x264 paquet ubuntu ou compilé?
« Reply #3 on: January 28, 2013, 11:07:16 AM »
Bon à force de tester je vais mettre ma procédure complète que j'ai utilisé pour que ça marche correctement avec la compilation de avidemux 2.6 via les sources svn.

Code: [Select]
git clone git://git.videolan.org/x264.git ~/x264
cd ~/x264
./configure --prefix=/usr --enable-static --enable-shared
make -j4
sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | \
  awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes \
  --fstrans=no --default

Mais avant j'avais aussi compilé yasm 1.2

Code: [Select]
cd
wget http://www.tortall.net/projects/yasm/releases/yasm-1.2.0.tar.gz
tar xzvf yasm-1.2.0.tar.gz
cd yasm-1.2.0
./configure
make
sudo checkinstall --pkgname=yasm --pkgversion="1.2.0" --backup=no \
  --deldoc=yes --fstrans=no --default

@+