Author Topic: Avidemux 2.6.6 problems -_-  (Read 2536 times)

phaolo

  • Newbie
  • *
  • Posts: 33
Avidemux 2.6.6 problems -_-
« on: November 12, 2013, 11:32:48 PM »
I feel like I'm spamming the forum today, but what the hell.. I like avidemux, but these 2.6.X versions are really full of problems.

I saved an .avi file with copy method and only shifting its tracks:
source = avi, codec xvid, 1330Mb, ac3 tracks
result = avi, codec xvid, 892Mb, ac3 tracks --> silent in vlc!

Other generic problems:
- avidemux locks each opened file, even when they have been closed, until the program is exited.
- skipping to the end always gives the usual reported error. Even with the scroller, some few frames aren't still reachable, you have to press "right" key till the end.
- ok, avidemux is optimized only for multicore, so I have to wait a lot for each opened avi (sigh).. but why does its win explorer folder "freeze" until the program finishes loading it?
- default avidemux volume is too high and, when modified, it changes all system wave volume.
- audio playback in avidemux is weird: after you press play, sometimes it's mute for a while, often it's out of sych for a while. Precise cuts are hard..
- how do I clear markers? Is there a button\menu\hotkey?
- see my thread about scripts for another problem with .mp4 output ( http://www.avidemux.org/smf/index.php/topic,13302.0.html ).
- zoom doesn't still work during playback.
« Last Edit: November 17, 2013, 11:51:30 AM by phaolo »

phaolo

  • Newbie
  • *
  • Posts: 33
Re: Avdemux 2.6.6 problems -_-
« Reply #1 on: November 15, 2013, 08:39:26 PM »
bump!!

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avdemux 2.6.6 problems -_-
« Reply #2 on: November 16, 2013, 05:52:42 AM »
No need to BUMP.
Its clearly pointed out in this forum that for serious work with older codecs, use avidemux 2.5.6.
You are playing with xvid, an older codec.

That said I've just used the latest nightly 2.6.6 to recode to xvid with copy on the ac3 sound tracks.
No problem at all.

No locking of files until the program is exited here.
Win explorer folder freezing until loading ends - not true (but I think you mean the GUI).


phaolo

  • Newbie
  • *
  • Posts: 33
Re: Avdemux 2.6.6 problems -_-
« Reply #3 on: November 16, 2013, 11:50:01 AM »
Thanks Aquar, but..

Quote
with older codecs, use avidemux 2.5.6 [...]
I've just used the latest nightly 2.6.6 [...]
Wait, my last 2.5.X version is 2.5.4, and it didn't work with 2 tracks.. I'll check 2.5.6 then.
About 2.6.6, I always try to use the most "stable" versions and avoid nightly builds.
Anyway I don't understand, will you ever create an unique avidemux version, or it will continue to have 2 active versions at the same time?

Quote
No locking of files until the program is exited here.
My os is still winXP with an old pc, I don't know if this will happen on new computers.
Can you try this: open file in avidemux, close it from the menu but keep program active, delete file-->locked?

Quote
Win explorer folder freezing until loading ends.
Yes, I meant the folder gui. Weird, it happens with 2.5.4 too for me.

What about the other problems?
« Last Edit: November 16, 2013, 12:48:23 PM by phaolo »

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avdemux 2.6.6 problems -_-
« Reply #4 on: November 17, 2013, 07:24:25 AM »
@ phaolo

Only the people involved in developing avidemux know where they are taking this tool.
From what I can tell, 90% of this work is being done by the one person.
That person also administers this forum ie mean.

There are a few people that provide sideways support like compiling the source code for different platforms.
And sadly this appears to be a much under appreciated service by most endusers.

There are also a few endusers like me that sometimes try to help other endusers a little bit.
We do not have a nitty gritty understanding of media constructs but just have a bit more video processing experience.
Also may cause our advice to be WRONG.

IMO the nightly versions of avidemux version 2.6.x are the most developed and bug corrected.
Hence the latest nightly is the most stable version for this development branch of avidemux.
This branch relies on time stamps embedded in the container and data packets as needed for compatibility with modern codecs.

Avidemux 2.5.6 is a finished program and so you could call that the most stable final release of that branch.
It's dated but probably the best fit for old computers. 
This branch relies on a simpler frame to time relationship, so is fine for older codecs that have a constant frame rate and frame display time.
This is not so good for modern codecs that vary the frame rate and vary the presentation time of each frame.

I don't understand the objection to the GUI being "frozen" whilst you are loading a media file into it.
If your PC is so slow that it takes a long time to load then it is too slow to multitask with another activity.
On any reasonably modest PC the time involved with the loading process, indexing and unpacking is not that much.
On windows 7 you can always bring up the desktop and start another activity.
 
Media files not in use anymore by avidemux are not locked in any way on my systems.

« Last Edit: November 17, 2013, 07:49:26 AM by AQUAR »

cliffshit

  • Newbie
  • *
  • Posts: 43
Re: Avdemux 2.6.6 problems -_-
« Reply #5 on: November 17, 2013, 08:12:58 AM »
I don't understand the objection to the GUI being "frozen" whilst you are loading a media file into it.
...
I think he means when adding a file to Avidemux from Windows Explorer with drag and drop?
Then the Explorer window indeed is "frozen" till the file is opened/indexed.
If you need just open a new window, thats not really a problem...
(and lots of other programs do the same, e.g. Audacity)

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avdemux 2.6.6 problems -_-
« Reply #6 on: November 17, 2013, 09:02:23 AM »
On my 64 bit windows 7 PC
 - drag and drop onto 2.5.6 neither freezes the GUI or the Windows Explorer during the loading process.
 - drag and drop onto 2.6.6 does freeze the GUI but not the Windows Explorer during the loading process.
The desktop icons behind the GUI are not accessible during the freeze, that might be annoying to some people (not me!).

Also with 2.6.6 the GUI freezes on top of the desktop during encoding - you can use start + tab to page other open windows - or set preferences so that avidemux minimises to the systray.

On my 32 bit windows 7 PC
 - drag and drop onto 2.5.4  doesn't work at all.

Mostly these behaviours are caused by how you setup the program - installer or nightly or portable - user or admin - user account security setting etc.

Personally I never use drag and drop and simply ignore these inconsequential items (call it avidemux character!).
« Last Edit: November 17, 2013, 11:28:55 AM by AQUAR »

phaolo

  • Newbie
  • *
  • Posts: 33
Re: Avdemux 2.6.6 problems -_-
« Reply #7 on: November 17, 2013, 11:49:50 AM »
Quote
I don't understand the objection to the GUI being "frozen" whilst you are loading a media file into it. If your PC is so slow [..]
If you need just open a new window, thats not really a problem[..]
My pc is a single core with Xp. It works fine with 2.5.X and normal quality files. I am admin and the setup was full.
Mean said that 2.6.X is developed for multicore, so on my pc for some media (avi) it takes even 1 minute to load a 30 sec video. (building,decompressing,etc)
And yes, with drag&drop in the meantime the win explorer folder GUI is frozen.
I am accepting these minor annoying problems, but they ARE problems and I think I should report them (hoping they will be fixed someday).

Quote
From what I can tell, 90% of this work is being done by the one person.
That person also administers this forum ie mean.
Uh, I didn't know that all was made by 1 person! (wow congrats!)
Anyway, I'm just reporting problems.
Also, I'm bumping threads, because they get easily skipped.
(can you check this: http://www.avidemux.org/smf/index.php/topic,13302.0.html)

Quote
This branch relies on time stamps [..] this branch relies on a simpler frame to time relationship
I obviously accept the current state of the versions, but in theory I expect them to merge in the far future:
old codec detected-->frame method
new codec detected-->time method
single core detected-->no multicore method
etc..
« Last Edit: November 17, 2013, 11:51:59 AM by phaolo »

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avidemux 2.6.6 problems -_-
« Reply #8 on: November 17, 2013, 12:35:35 PM »
Reporting in the manner you have done is most proper.

I don't believe that avidemux will ever morph into a beast that caters for fading hardware and codecs.

That said, 2.6.6 lets me transcode from AVC to XVID without sync issues, and that is already pampering to the fading.
For now I like it because my media player wants xvid.

 



phaolo

  • Newbie
  • *
  • Posts: 33
Re: Avidemux 2.6.6 problems -_-
« Reply #9 on: November 17, 2013, 02:05:29 PM »
Version 2.5.6 doesn't even start on my pc. Now I see why I stopped at 2.5.4
Anyway, the new HQ codecs are great, but I have old videos with xvid that obviously won't change codec.
With the last XVID, then, I'm at a dead end with avidemux now.  :\

(And for 2.6.6 I'm stuck for batch processing a bunch of avc flv-to-mp4 files)

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avidemux 2.6.6 problems -_-
« Reply #10 on: November 18, 2013, 01:55:10 AM »
Well I am now guessing a bit when you are using 2.6.6 with this "last" XVID.

If the XVID you are copying is smaller in size then maybe one of its tracks isn't being copied in the process.
So has it got 2 audio tracks, are you selecting both and are you remuxing into a container capable of multiple audio tracks.

Normally the avi container can only hold one audio track (when using 2.5.x).
Avidemux does have a tweaked AVI muxer for putting 2 audio tracks into an avi container.



« Last Edit: November 19, 2013, 11:45:02 AM by AQUAR »

phaolo

  • Newbie
  • *
  • Posts: 33
Re: Avidemux 2.6.6 problems -_-
« Reply #11 on: November 18, 2013, 11:33:07 AM »
Quote
maybe one of its tracks isn't being copied
Mediainfo reports 2 ac3 tracks in the result, but they are both silent in vlc.
I've just shifted both in avidemux by 0.5\1 secs in copy mode and saved the file.

Quote
Normally the avi container can only hold one audio track. Avidemux does have a tweaked AVI muxer
Well, the source is an .avi and I'm using the same for the output.
I could try changing the container, but I'd prefer to avoid that.

Quote
with this "last" XVID
what's wrong? Sorry I'm not english, I meant the xvid video mentioned in this thread.
« Last Edit: November 18, 2013, 11:35:09 AM by phaolo »

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avidemux 2.6.6 problems -_-
« Reply #12 on: November 19, 2013, 09:10:03 AM »
Probably a good idea to look at the avidemux wiki for information on how to do multi track audio.

When you use a video editor like avidemux in copy mode, you are first demuxing a media file into its constituent raw data streams.
Then you set up the editor to rebuild that media file by selecting the video and audio and any other data streams you want.

By default the avidemux 2.6 copy process will select the video and all the audio tracks for remuxing into a suitable container (including avi muxer). If you use avidemux 2.5.6 you need to select the dual audio avi muxer.

If the AC3 audio tracks don't play in vlc then they are probably corrupt in some way. 
« Last Edit: November 19, 2013, 11:33:43 AM by AQUAR »

phaolo

  • Newbie
  • *
  • Posts: 33
Re: Avidemux 2.6.6 problems -_-
« Reply #13 on: November 21, 2013, 07:10:25 PM »
Version 2.5.6 doesn't work for me. In 2.5.4 there is only one avi muxer.

AQUAR

  • Hero Member
  • *****
  • Posts: 612
Re: Avidemux 2.6.6 problems -_-
« Reply #14 on: November 22, 2013, 11:16:17 AM »
Should work on XP - maybe uninstall first?