Author Topic: Howto install Avidemux 2.6 on OSX using Homebrew  (Read 77255 times)

nibbles

  • Sr. Member
  • ****
  • Posts: 292
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #30 on: April 28, 2012, 06:15:04 AM »
Homebrew has patched cmake-2.8.8 using the Kitware patch for pkg-config that will appear in cmake-2.8.9.  I tested Homebrew's patched cmake with avidemux-2.5 and 2.6.  Both build without error.  If you want to get the patched cmake, you need to:

Code: [Select]
brew update
brew rm cmake
brew install cmake

After that you can build 2.5 or 2.6 as usual.

fedep

  • Newbie
  • *
  • Posts: 1
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #31 on: May 08, 2012, 01:07:45 PM »
 I do all the steps recommended... and now?  How I can start avidemux?  :-[

styrol

  • Hero Member
  • *****
  • Posts: 533
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #32 on: May 08, 2012, 03:01:48 PM »
If you built 2.6 just open "avidemux" in

/usr/local/Cellar/avidemux3/2.6/bin/

Avidemux 2.5 should also reside in /usr/local/Cellar/

There is a symlink in /usr/local/bin. Best way you create an alias from there and place it in your application folder.
« Last Edit: May 08, 2012, 07:20:04 PM by styrol »

CyberGene

  • Newbie
  • *
  • Posts: 1
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #33 on: May 26, 2012, 08:21:46 PM »
I tried to build avidemux 2.6 and I get the following error:

Code: [Select]
brew install avidemux3
==> Cloning git://gitorious.org/avidemux2-6/avidemux2-6.git
Updating /Library/Caches/Homebrew/avidemux3--git
Error: private method `split' called for #<Array:0x109a57558>
Please report this bug:
    https://github.com/mxcl/homebrew/wiki/reporting-bugs
/usr/local/Library/Formula/avidemux3.rb:36:in `process'
/usr/local/Library/Homebrew/extend/fileutils.rb:35:in `mkdir'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:121:in `chdir'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:121:in `chdir'
/usr/local/Library/Homebrew/extend/fileutils.rb:34:in `mkdir'
/usr/local/Library/Formula/avidemux3.rb:35:in `process'
/usr/local/Library/Formula/avidemux3.rb:73:in `install'
/usr/local/Library/Homebrew/build.rb:98:in `install'
/usr/local/Library/Homebrew/formula.rb:192:in `brew'
/usr/local/Library/Homebrew/formula.rb:524:in `stage'
/usr/local/Library/Homebrew/extend/fileutils.rb:22:in `mktemp'
/usr/local/Library/Homebrew/formula.rb:520:in `stage'
/usr/local/Library/Homebrew/formula.rb:187:in `brew'
/usr/local/Library/Homebrew/build.rb:77:in `install'
/usr/local/Library/Homebrew/build.rb:40
/usr/local/Library/Formula/avidemux3.rb:103

I've done everything as explained and have been very careful to not miss anything starting with the installation of Homebrew, Ruby, etc. I am myself a Java Developer.

nibbles

  • Sr. Member
  • ****
  • Posts: 292
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #34 on: June 01, 2012, 08:17:56 AM »
Sorry about that @CyberGene.  Homebrew changed their installer code recently.  When I modified the formula to use their new variables, I made a mistake by leaving in the 'split' command.  I fixed that within a day or two and made a commit, but I stepped away from my computer and forgot to push the change to the main repo until today.  Please download the updated avidemux3.rb formula from Page 1, and try again.  I just used that link and verified that everything works.
« Last Edit: June 01, 2012, 08:26:29 AM by nibbles »

Timor

  • Newbie
  • *
  • Posts: 3
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #35 on: June 12, 2012, 04:23:31 PM »
@nibbles

At first, I've tried the macports script, which fails after some hours.

With Homebrew I was able to build 2.5.6.

But I can't build 2.6 (missing formula for avidemux3 in Homebrew).

EDIT: Sorry :) I've forgotten to download the formula.

It works :)

Cu, Timor
« Last Edit: June 12, 2012, 06:29:30 PM by Timor »

eya

  • Newbie
  • *
  • Posts: 1
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #36 on: August 02, 2012, 06:56:32 PM »
I always get this error

Code: [Select]
==> Downloading http://pkgconfig.freedesktop.org/releases/pkg-config-0.27.tar.gz

curl: (7) couldn't connect to host
Error: Download failed: http://pkgconfig.freedesktop.org/releases/pkg-config-0.27.tar.gz

styrol

  • Hero Member
  • *****
  • Posts: 533
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #37 on: August 02, 2012, 07:06:44 PM »
Quote
curl: (7) couldn't connect to host
Server down? Try again 24h later.

btb

  • Newbie
  • *
  • Posts: 1
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #38 on: August 12, 2012, 09:26:12 PM »
brew install --HEAD avidemux
doesn't work on Mountain Lion:
Code: [Select]
Building CXX object ADM_videoFilters/FluxSmooth/CMakeFiles/ADM_vf_FluxSmooth.dir/ADM_vidFlux.cpp.o
Linking CXX shared library libADM_vf_Stabilize.dylib
/tmp/homebrew-avidemux-HEAD-HPkJ/plugins/ADM_videoFilters/FluxSmooth/ADM_vidFlux.cpp:459:1: error: couldn't allocate input reg for constraint '{_l_src_pitch}'
"                                                                mov (%0),"REG_si" \n\t"
^
/tmp/homebrew-avidemux-HEAD-HPkJ/plugins/ADM_videoFilters/FluxSmooth/ADM_vidFlux.cpp:644:5: error: ambiguous instructions require an explicit suffix (could be 'subb', 'subw', 'subl', or 'subq')
" \n\t"
    ^
<inline asm>:267:18: note: instantiated into assembly here
                        sub $1, ycnt(%rip)
                        ^
2 errors generated.

full log:
https://gist.github.com/3334551

Menneisyys

  • Newbie
  • *
  • Posts: 3
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #39 on: August 19, 2012, 10:23:20 PM »
brew install --HEAD avidemux


I've just installed it, following the tutorial; on my ML, it installed just fine.

Menneisyys

  • Newbie
  • *
  • Posts: 3
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #40 on: August 19, 2012, 10:25:42 PM »
There seems to be no avidemux3 formula any more.

When I list the list of formulas starting with avi (with "brew search avi"), I only get avidemux (that is, 2.5.5 r7908) but not  avidemux3.

What can the problem be?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 3477
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #41 on: August 20, 2012, 06:21:38 AM »
Myself not an apple user. Looks like 2.6 is not in homebrew mainstream.
Home brew formula tells:
Code: [Select]
6 url 'http://downloads.sourceforge.net/avidemux/avidemux_2.5.6.tar.gz'
9 head 'http://svn.berlios.de/svnroot/repos/avidemux/branches/avidemux_2.5_branch_gruntster'
This should be 2.5.6 version.
My guess is you need to download the formula from this page: Howto build Avidemux2 using Homebrew on Snow Leopard or Lion under the header: Info On Building 2.6, can't tell if this would currently build, as users reported issues with building. I've not seen reports this is fixed/or a fix is working?
« Last Edit: August 20, 2012, 07:11:59 AM by Jan Gruuthuse »

nieder

  • Newbie
  • *
  • Posts: 4
Re: Howto build Avidemux using Homebrew on Snow Leopard or Lion
« Reply #42 on: September 06, 2012, 09:08:57 PM »
brew install --HEAD avidemux
doesn't work on Mountain Lion:
Code: [Select]
Building CXX object ADM_videoFilters/FluxSmooth/CMakeFiles/ADM_vf_FluxSmooth.dir/ADM_vidFlux.cpp.o
Linking CXX shared library libADM_vf_Stabilize.dylib
/tmp/homebrew-avidemux-HEAD-HPkJ/plugins/ADM_videoFilters/FluxSmooth/ADM_vidFlux.cpp:459:1: error: couldn't allocate input reg for constraint '{_l_src_pitch}'
"                                                                mov (%0),"REG_si" \n\t"
^
/tmp/homebrew-avidemux-HEAD-HPkJ/plugins/ADM_videoFilters/FluxSmooth/ADM_vidFlux.cpp:644:5: error: ambiguous instructions require an explicit suffix (could be 'subb', 'subw', 'subl', or 'subq')
" \n\t"
    ^
<inline asm>:267:18: note: instantiated into assembly here
                        sub $1, ycnt(%rip)
                        ^
2 errors generated.

full log:
https://gist.github.com/3334551

I'm getting an identical failure when building avidemux 2.5.6 on Lion (manual, not via homebrew).  Has there been good resolution for this error?  I locally patched ADM_vidFlux.cpp:645 to use 'subl' instead of 'sub', and that lets the build continue, but I have no idea if that's the correct solution.

nibbles

  • Sr. Member
  • ****
  • Posts: 292
Re: Howto build Avidemux on OSX 10.6, 10.7, or 10.8 using Homebrew
« Reply #43 on: September 09, 2012, 06:19:20 AM »
VidFlux has been a problem on OSX for a long time.  When I posted this error to llvm.org, I was told that it was fixed in svn.  I did not find that to be the case.  So Homebrew compiles Avidemux-2.5 using llvm-gcc, not clang, and we keep hoping that it will get fixed.  Because you posted the first possible solution to this, we'll have to get Mean to weigh in and tell us if that is reasonable. This is like the one bug I was never able to solve.  So thanks for posting.  He may not see this post or have time to work on 2.5, though. 

kenshin3it

  • Newbie
  • *
  • Posts: 29
Re: Howto build Avidemux on OSX 10.6, 10.7, or 10.8 using Homebrew
« Reply #44 on: October 03, 2012, 09:41:59 AM »
Hi,
 i've tried to build avidemux3 but i can't run the application.
i've tried to reinstall avidemux with option --HEAD,but now when i run the application i'm getting this crash report:
Code: [Select]
Dyld Error Message:
  Library not loaded: /usr/local/lib/libpng15.15.dylib
  Referenced from: /usr/local/lib/QtGui.framework/Versions/4/QtGui
  Reason: image not found
i think the issue is about qt 4.8.3,how can install qt 4.8.2?
i have an iMac 7,1 with 10.8.1 .
thank you.
iMac 24\" Intel Core 2 Duo@2.4GHz - OSX 10.6.1